alxndrlsn
@alxndrlsn
Инженер

Где теперь взять offline установщик Qt5 под Linux?

Друзья, вопрос актуальный, начиная с февраля-марта этого года: где теперь взять offline установщик Qt5.15+ (ну или Qt6, чего уж там) под Linux (Debian, Ubuntu, Mint)?

Вариант со сборкой из исходников оказался для меня пока что неподъемным: где-то допускаю ошибку и в итоге классы в проекте обозначаются как неизвестные, а WebEngine вообще не собрался, ругнувшись: could not find all necessary libraries for qpa-xcb support in qtwebengine , кроме того ругался после make install еще чем-то "не могу создать каталог такой-то: отказано в доступе" и т.п. ... (собирать из исходников пытался под свежей Mint, клонируя из репозитория по инструкции Building_Qt_5_from_Git).

Вариант установить через snapd подкупал своей простотой (казалось бы, всего-то нужно: включить поддержку snaps, переместив файлик nosnap.pref куда-нибудь в HOME), однако после установки snapd и запуска соответствующей команды на установку снапа qt515-core20, он вроде установился, но куда - обнаружить не удалось, даже через Qt Creator. Видимо, снова не тот путь...

Собственно, вопрос актуальный в нашей стране со времен Чернышевского, а может и до него: что делать? Если есть проверенные идеи и пошаговые инструкции по поиску/установке Qt5.15+ (ну или Qt6, чего уж там) - you are welcome!
  • Вопрос задан
  • 554 просмотра
Решения вопроса 1
@xibir
Ответ написан
Комментировать
Пригласить эксперта
Ответы на вопрос 4
@AVKor
На Debian проще некуда: apt install ....
Ответ написан
Комментировать
Sanes
@Sanes
вроде установился, но куда - обнаружить не удалось

ls /snap
Ответ написан
Комментировать
CityCat4
@CityCat4
Жил-был у бабушки серенький троллик...
А что, все пакеты под дебиан и бубунту - так вот взяли и отовсюду пропали?

Я вот не компостируя мозги делаю
emerge -av qtcore
(хотя конечно же совсем без компостирования мозгов оно не пройдет - разгребать постоянные конфликты версий при сборке qt - это ад ацкий)
Ответ написан
Комментировать
@cycloclimber
Для ubuntu 22.04 вот так, например: https://askubuntu.com/questions/1404263/how-do-you...

Для Fedora все ставится нормально из flathub
Ответ написан
Комментировать
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы