@zaralX
Я человек, я упал с луны.

Как решить ошибку версии Java в intellj idea?

Caused by: java.lang.UnsupportedOperationException: You are using an outdated version of Java (8). Java 17 or higher is required.

Я уже скачивал jdk 17 и 18 и в JAVA HOME прописана java 17 и всё равно ничего я непонимаю что делать :(
  • Вопрос задан
  • 50 просмотров
Решения вопроса 1
@zaralX Автор вопроса
Я человек, я упал с луны.
скачал liberica-18 установил все настрйоки перезагрузил 2 раза комп установил JAVA_OPTIONS -Xmx 4G (Внимание! некоторые приложения с java перестанrт рабротать) потом переставил заново Java_home перезагрузил 3 раза комп удалил саму джаву перезгрузил комп скачал заного снова перезагрузил и заработало..

Цыганские фокусы..
Ответ написан
Комментировать
Пригласить эксперта
Ответы на вопрос 2
xez
@xez
Senior Junior Roo
Удалите java 8
Проверьте в командной строке вывод: java —version
Ответ написан
Jacen11
@Jacen11
я так понимаю запуск через идею. Она позволяет использовать разные jdk, это путает новичков. В Project setting посмотрите что стоит как сдк и какой lvl
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы