@AutoGG

Ошибка с версией при получение key, server, ts vk_api?

Пытаюсь получить key, server, ts данным кодом:
import requests
token = 'vk1.a.vcneF2mcpQw3w06u8dHjpRGr7YLezyJDYKKq-ykDPd5kFQWMMSrcA_crwMuss5RVH2lbYP6BZvLlIzaovj_sVC-4m6nQoN-hReo2S3vxbPz4azN8O5HXT2YXGv9dwd6zRKz6Fgvz9LXMNeG26bsw3fjhSklHtFzK-Pe1hRcrCKZmZYheLbGdw-WUNf*****'
data = requests.get('https://api.vk.com/method/messages.getLongPollServer',
params={'access_token': token}).json()
print(data)

Но при запуске получаю ошибку:
{'error': {'error_code': 8, 'error_msg': 'Invalid request: v is required. Version param should be passed as "v". "version" param is invalid and not supported.', 'request_params': [{'key': 'method', 'value': 'messages.getLongPollServer'}, {'key': 'oauth', 'value': '1'}]}}


Кто сталкивался с ошибкой не могли бы помочь? Заранее Спасибо.
  • Вопрос задан
  • 29 просмотров
Решения вопроса 1
AndreasFxPro
@AndreasFxPro
Програмирую на языке python. Увлекаюсь парсингом
Пишет же, что ему надо передавать ещё версию через параметр "v".
params={'access_token': token, 'v': 2}
+ ссылаюсь на документацию
version — версия. Актуальная версия: 3. Для версии 0 (по умолчанию) идентификаторы сообществ будут приходить в формате group_id + 1000000000 для сохранения обратной совместимости. Мы рекомендуем использовать актуальную версию.
Ответ написан
Комментировать
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы