@anon123565

Как в excel заменить значения в ячейках которые содержат определенные значения в соседнем столбце?

Ну например, как мне сделать чтобы только там где "od_1" поменять значение "test" на "super".

62b98aa3d12a7763396052.png
  • Вопрос задан
  • 77 просмотров
Решения вопроса 2
BasiC2k
@BasiC2k
Решаю проблемы за деньги. Дорого.
Как вариант - в третьей колонке ("С") поставить формулу:
=ЕСЛИ(A1="od_1";"super";B1)
и растянуть её вниз.
Суть формулы. Если в рассматриваемой строке, в ячейке"A1" указано значение "od_1", то в ячейке "C1" указать "super". Иначе - указать значение из "B1". И так по каждой строке таблицы.
После вычислений, значение столбца "С" можно скопировать и через специальную вставку - вставить только значения вместо столбца "В".
Все.

PS. Если в задании во второй колонке ("В") должна быть проверка значения на "test" - формулу легко дополнить вторым условием.
Ответ написан
ProgrammerForever
@ProgrammerForever
Учитель, автоэлектрик, программист, музыкант
1) Скопировать2 столбца в Notepad++
2) Замена (Ctrl+H)
od_1\t(.*?)\n
od_1\tsuper\n
в режиме регулярных выражений
62b999eedb2c4350663436.png
3) Скопировать обратно всё в Excel
Ответ написан
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы