Как использовать библиотеку, если она не поддерживает мою версию реакта?

Что-то юзал юзал одни и те же пакеты на джаваскрипте, все было круто
Сейчас столкнулся с проблемой, что дописал проект, мне в конце надо добавить библиотеку
https://github.com/klendi/react-top-loading-bar
а она не поддерживает 18 версию реакта, что в таких ситуациях делают, если я версию реакта снижу, мб у меня что-то другое сломается
просто смирится и искать другие варианты ?
Вопрос больше не про конкретный случай, а про общую практику
Подскажите молодому не опытному, пожалуйста
  • Вопрос задан
  • 56 просмотров
Решения вопроса 1
Seasle
@Seasle
\( ゚ヮ゚)/
Можете написать свою обёртку - https://github.com/rstacruz/nprogress
Ответ написан
Комментировать
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы