@lolSaByR

Как «починить» убунту?

Накосячил в терминале, сам того не поняв, как... В общем, стоит Ubuntu 20.04, пытался обновить git, и вылетает ошибка...
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Вы можете запустить «apt --fix-broken install» для исправления этих ошибок.
Следующие пакеты имеют неудовлетворённые зависимости:
 libc6-dbg : Зависит: libc6 (= 2.31-0ubuntu9.9) но 2.31-0ubuntu9.7 уже установлен
 libc6-dev : Зависит: libc6 (= 2.31-0ubuntu9.9) но 2.31-0ubuntu9.7 уже установлен
 libc6-i386 : Зависит: libc6 (= 2.31-0ubuntu9.9) но 2.31-0ubuntu9.7 уже установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt --fix-broken install», не указывая имени пакета (или указав решение).


Теперь из-за этого не могу обновить систему и скачивать/удалять что-либо
  • Вопрос задан
  • 263 просмотра
Пригласить эксперта
Ответы на вопрос 3
@Drno
черным по белому написано что надо запустить...
Ответ написан
smorman
@smorman
When In Rome do as The Romans do...
Вам же вывод подсказывает, что сделать.

sudo apt install -f
Ответ написан
justhostRU
@justhostRU
список реп в студию
cat /etc/apt/sources.list

apt update; - ВСЕ репы обновляет?
apt upgrade
попробовать разрулить зависимости через aptitude. не помню, кнопкой f или g в нём.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы
AgentApp Санкт-Петербург
от 250 000 ₽
SberTech Москва
от 200 000 до 300 000 ₽
от 200 000 до 250 000 ₽