Queen2
@Queen2

Не работает атрибут muted у тега видео. Как испрвить?

С помощью события Onclick добавляю видео на сайт и все атрибуты отрабатывают корректно кроме "muted"
Что в коде не так?

let button = document.getElementById('check_answer');
let input_number = document.getElementById('password');
let correct_answer = document.createElement('div');
let correct_answer_video = document.createElement('video');
let block = document.createElement('div');

correct_answer_video.className= 'answer';
correct_answer_video.setAttribute('autoplay', 'autoplay');
correct_answer_video.setAttribute('src', './img/123.mp4' );
correct_answer_video.setAttribute('loop', 'loop');
correct_answer_video.setAttribute('height', '500');
correct_answer_video.setAttribute('muted', 'muted');

button .onclick = show;

function show(){
    if(input_number.value == 1715){
        document.body.append(correct_answer);
        document.body.append(block);
        document.body.append(correct_answer_video);
    }

Пробовал пробовал с помощью события создать блок и в нем уже видео но тогда "autoplay" не отрабатывает.
correct_answer.className = 'answer';
correct_answer.innerHTML = '<video  controls="controls" autoplay ="autoplay" loop="loop" height="500" muted="muted" src="./img/123.mp4"></video>'
  • Вопрос задан
  • 105 просмотров
Пригласить эксперта
Ответы на вопрос 1
sashabeep
@sashabeep
Дней без вопросов про Slick на тостере : 0
autoplay не может включиться у видео со звуком, сначала надо установить muted
Ответ написан
Комментировать
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы