@Undefinedy

Как обновить зависимость у зависимости?

У меня в проекте есть file-loader (расположений в my-project/node_modules/file-loader)
и внутри этого file-loader-а есть loader-utils (расположений в file-loader/node_modules/loader-utils)
мне нужно обновить loader-utils с версии ^2.0.0 до ^3.2.0
я не могу использовать yarn upgrade loader-utils@3.2.0 в директории file-loader-a так как там нет ни package.lock.json ни yarn.lock
могу ли я как-то заставить file-loader использовать другую версию loader-utils?
  • Вопрос задан
  • 188 просмотров
Решения вопроса 1
Aetae
@Aetae
Тлен
Ты можешь воспользоваться yarn resolutions для перезаписи зависимостей. Однако следует помнить, что разные мажорные версии (2 и 3 соответственно) могут иметь ломающие различия в api.
Ответ написан
Комментировать
Пригласить эксперта
Ответы на вопрос 1
Ответ написан
Комментировать
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы