@Perokar

В node-telegram-bot-api не работают callback_data/callback_query?

Вопросов несколько самый основной здесь, остальные выложу чуть позже:

const TelegramApi = require('node-telegram-bot-api');
const { addNewUser, checkUser, clearUser, User, update } = require('./schems/userSchema');
const { addPost, clearPost, sendStartPost } = require('./schems/postSchema');
const { send, day7} = require('./send/send')
require('dotenv').config('')
const token = process.env.TOKEN;

const bot = new TelegramApi(token, { polling: true });

const keyboardOption ={
  reply_markup: {
    inline_keyboard:
      [
        [
          { text: "Да", callback_data: '1' },
          { text: "Нет", callback_data: '0' }
        ]
      ]
  }
}
bot.onText(/\/d7/, (msg,prop)=>{
  bot.sendMessage(msg.id.chat,  ' some text',  keyboardOption)
})
bot.on("message", async (msg, prop) => {
  const id = {
    userId: msg.from.id,
    userName: msg.from.first_name,
    dateNow: new Date().getDate(),
    status: 'day0'
  }
  if (msg.text == '/start') {
    addNewUser(id);
    const messageArr = await sendStartPost();
    messageArr.forEach((text) => {
      bot.sendMessage(msg.from.id, text.post, { parse_mode: 'Markdown', disable_web_page_preview: true });
    })
  }
  if (msg.text == '/update') {
      update();
      
  }
  if (msg.text == "/add") // поиск
  {
    addPost();
  }

  if (msg.text == "/find") // Добавление в базу
  {
    checkUser('day1');
  }
  if (msg.text == "/clean") // Удаление из базы
  {
    clearPost();
    clearUser();
    bot.sendMessage(msg.from.id, "База обнулена")
  }
  console.log('msg did not handle');
})
bot.on('callback_query', msg => {
  console.log(msg);
})

Так вот слушатель callback_query ничего не улавливает ни на локальном компьютере, ни на сервере, не могу понять то-ли библиотека здохла, то ли я что-то туплю.? ПАмАгитиии!
  • Вопрос задан
  • 24 просмотра
Пригласить эксперта
Ответы на вопрос 1
@Perokar Автор вопроса
Возможно кому-то будет полезно. Вопрос решился неожиданным образом.
Нужно обновить пакет node-telegram-bot-api.
У меня автоматом установилась версия ^0.18.
Что бы установить актуальную, заходите на сайт пакета, смотрите версию, и потом прописываете её в package.json напротив установленного пакета
Ответ написан
Комментировать
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы
от 150 000 до 300 000 ₽
deeplay Новосибирск
До 300 000 ₽
SPORA Москва
от 180 000 до 250 000 ₽
24 янв. 2022, в 12:54
1 руб./за проект
24 янв. 2022, в 11:51
1500 руб./за проект