Mikrotik. Как сделать автоматическое переподключение в зависимости от IP?

Имеется подключение к провайдеру по PPPoE, IP динамический.
По тарифу должен всегда выдаваться «белый» IP, но бывает провайдер иногда выдаёт IP за своим NAT из-за чего перестаёт работать внешний доступ. Приходится вручную переподключать соединение для получения нормального IP.

Интересует вопрос автоматизации. Знаю, что можно реализовать при помощи скриптов, но в их написании я не силён.
Что требуется: если IP на интерфейсе из 10.0.0.0/8 сделать enable/disable этого подключения.
  • Вопрос задан
  • 314 просмотров
Пригласить эксперта
Ответы на вопрос 2
iAHTOH
@iAHTOH
Инженер ПНР АСУ ТП
А не проще в этом случае настроить Watchdog Timer и указать в нем ваш статический IP?
В случае если роутер получить другой IP то он перегрузится. Времена ожидания можно настроить тамже.
System - Watchdog
Ответ написан
Ten
@Ten
У меня сделано так. Здесь ещё в телеграмм сообщение откидывается, но можно и без.

в On Up:
/log info "ISP Connected, timeout 30s...";
:delay 30s
:local curIP [/ip address get [find interface="Rostelecom"] address]; :put $curIP
:if ($curIP in 100.64.0.0/10) do={
/tool fetch url="https://api.telegram.org/bot13XXXXXXXXXX:AAHWol7bw... bad address got! - $curIP";
/interface pppoe-client disable Rostelecom
:delay 5s
/interface pppoe-client enable Rostelecom
} else {
/tool fetch url="https://api.telegram.org/bot13XXXXXXXXXX:AAHWol7bw... GOOD address got! - $curIP";
}

в On Down:
/log info "ISP Disconnected!";

6196040cd53b4327158919.png
Ответ написан
Комментировать
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы