@stainer

Как совместить elasticsearch и php 7.0?

Доброго дня!
Дано: крупный проект на php 7.0 + elasticsearch 7.15.1.
Возникла проблема, библиотеки официальная elasticsearch/elasticsearch и пара популярных сторонних для работы работы хотят php >= 7.3.
(Эластик только вводится, а не уже встроен)

Варианты:
1) Переделать проект под php 7.3
Проект сложный и хочется понять насколько сложно сделать апдейт на 3 версии.
2) Использовать старую версию эластика (~2019 года)
Последняя версия либы, которая поддерживала php 7.0 - v6.7.2. Хочется понять насколько она актуальна сейчас
3) Писать кастомную либу
Написать свой rest апи клиент.

Хочется понять трудности каждого из вариантов.
Большое спасибо!
  • Вопрос задан
  • 83 просмотра
Пригласить эксперта
Ответы на вопрос 2
Fockker
@Fockker Куратор тега PHP
Потомок старинного рода Ипатьевых-Колотитьевых
> хочется понять насколько сложно сделать апдейт на 3 версии.

Несложно. Отличия минимальны. В рамках одной мажорной версии вообще никаких проблем. Тут вопрос даже не в трудностях, а в том, что оставаться на 7.0 это вообще не вариант.
Только переезжать надо на 7.4, потому что поддержка 7.3 прекращается через месяц.

И вообще, версию надо подтягивать не когда жареный петух в зад клюнет, а планово.
Ответ написан
Хотел бы дополнить ответ выше - переписывать код непосредственно из-за переезда с PHP 7.0 версии не придётся. Но обновление PHP может повлечь за собой обновление других библиотек, интеграция или интерфейсы которых за эти годы могли уже поменяться.

Но даже в таком случае первый вариант должен быть в приоритете - на актуализацию кодовой базы закрывали глаза уже 4 года, не стоит усугублять ситуацию.
Ответ написан
Комментировать
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы