partisan42
@partisan42
Новичок в Linux.

Как указать несколько адресов в address list?

Я создал запрещающее правило в firewall которое не даёт ходить всем участникам сети 192.168.0.0/24 на условный site.ru.

Но вся беда в том, что есть несколько человек, которым в на этот сайт всё же ходить нужно.
Первое что я подумал, это создать address list с нужными мне адресами, но столкнулся с проблемой, что нельзя просто взять и перечислить нужные адреса через запятую, а указывание диапазона мне не подходит, так как адреса не соседние. (192.168.0.8, 192.168.0.88, 192.168.0.92 и т.д.).

В самом правиле поставить восклицательный знак, и перечислить адреса, так же не получается.

Как можно реализовать подобное?
  • Вопрос задан
  • 104 просмотра
Решения вопроса 1
Maxlinus
@Maxlinus
создаём нужные адрес листы с сайтами и компами
/ip firewall address-list
add address=192.168.0.21 list=pc
add address=192.168.0.28 list=pc
add address=192.168.0.32 list=pc
add address=site.ru list=block


создаём правило, где указываем куда ходить нельзя и кто в исключении, указываем в нем адрес листы
/ip firewall filter
add action=drop chain=forward dst-address-list=block src-address-list=!pc


правило поднять вверх .
Ответ написан
Комментировать
Пригласить эксперта
Ответы на вопрос 1
partisan42
@partisan42 Автор вопроса
Новичок в Linux.
А всё, нашёл сам:)
Firewall Rules -> Правило -> Advanced -> Src Adress List, и уже там через запятую.
Хотя конечно через создание списка адресов это было бы удобнее. Может всё же кто нибудь поделиться такой мудростью?:)
Ответ написан
Комментировать
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы