@kiberlain

Как сгенерировать случайное слово из диапазона в ячейке рядом?

Решил сваять клавиатурный тренажёр для себя с частыми словами на базе libre calc.
Суть: имеется диапазон с набором готовых слов, которые часто приходится набивать на работе. Нужно чтоб кликнули в ячейку A1 и рядом в B1 появилось слово, которое нужно набрать вслепую. Саму генерацию я сделал, используя ВПР

615435049bae6448504468.png

но хочется приятного: написал в C1 слово (причём правильно) нажал enter и автоматом в B2 появляется следующее слово для набора. Как такое сделать?

PS: и ещё при нажатии на enter у меня все ячейки обновляются, как пофиксить?
  • Вопрос задан
  • 38 просмотров
Пригласить эксперта
Ответы на вопрос 1
ProgrammerForever
@ProgrammerForever
Учитель, автоэлектрик, программист, музыкант
В С2:
=ЕСЛИ(ИЛИ(C1="";ISFORMULA(C1));"";ИНДЕКС($B$1:$B$19;1+ЦЕЛОЕ(СЛЧИС()*СЧЁТЗ($B$1:$B$19))))

...и распространить вниз
Ответ написан
Комментировать
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы