@cereberlum

Как сменить версию php для mysql?

Сервер с панелью vesta крутится на centos 7 установил дополнительные версии пхп т.к. нужны для некоторых сайтов, но теперь не пашет phpmyadmin.....
PHP 7.1.3+ is required.
Currently installed version is: 5.6.40
Проверка версии на сервере показывает:
# php -v
PHP 7.4.6 (cli) (built: May 12 2020 08:09:15) ( NTS )
Copyright (c) The PHP Group
Zend Engine v3.4.0, Copyright (c) Zend Technologies

Подскажите как лечить это?
  • Вопрос задан
  • 101 просмотр
Решения вопроса 2
DevMan
@DevMan Куратор тега PHP
php -v - это консоль. веб-сервер может быть настроен на использование другой версии пыха.
для веб-сервера нужно смотреть выхлоп phpinfo().
как лечить на панелях понятия не имею.

и, как уже написали, лучше вообще не пользовать PMA.
Ответ написан
SignFinder
@SignFinder
Wintel\Unix Engineer
PHP в Linux присутствует в 4 основных ипостасях:
1. консольное приложение php
2. модуль для Apache
3. FPM модуль для nginx и т.п.
4. библиотека php-mysql

Все они могут быть разных версий, связанных или не связанных между собой.
Ответ написан
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы