@korner-brazers

Gulp как запечь ES6 под ES5?

Делаю проект на ES6, в проекте используется import и exrpot.
Все бы нечего, но нужно запечь одиночный файл под старые браузеры, но не могу найти как это сделать.

Вот отрывок из gulpfile.js

gulp.task('merge', function(){
    return (
        gulp.src(srcFolder+"app.js")
            .pipe(plumber())
            // Notice the name change.
            .pipe(concat("app.js"))
            .pipe(
                babel({
                    presets: ["@babel/env"]
                })
            )
            .pipe(gulp.dest(dstFolder))
    )
});


На выходе имею:

"use strict";

var _math = _interopRequireDefault(require("./utils/math"));

function _interopRequireDefault(obj) { return obj && obj.__esModule ? obj : { "default": obj }; }

console.log(_math["default"].twoPlusTwo());


Даже в современном браузере получаю ошибку на функцию require() Потому что этой функции не существует, а что там уж говорить про es5.

Как мне запечь одиночный файл под браузер?
  • Вопрос задан
  • 96 просмотров
Решения вопроса 1
@korner-brazers Автор вопроса
Все разобрался, использовал rollup.js
Ответ написан
Комментировать
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы