BenderIsGreat34
@BenderIsGreat34
junior front-end

Зависимости react-native и react-native-reanimated?

Помогите разобраться с зависимостями, проблема: был react-native 0.65.1, была либа react-native-reanimated 2.0.0. Оказалось, что react-native-reanimated не работает с рн 0.65, эта либа нужна для home навигации, они выпусстили альфа версию, которая должна была поддерживать 65 реакт, но по итогу она крашится как на иос, так и в андроиде, уже месяц обещают выпустить стабильный релиз, но судя по всему - не могут.
Я откатился до реакта 0.64.2, но теперь у меня в консоли сыпятся ошибки типа > Could not find com.facebook.fbjni:fbjni-java-only:0.0.3.
Короче, беда с зависимостями реакта. Какой есть выход из ситуации? Я могу как-то роллбекнуться без танцев с бубном?

Скачать эти файлы уже нету возможности, их подчистили с оф сайтов, в консоли падает ссылка, где бы я мог это скачать, но ссылки битые, пруф https://repo.maven.apache.org/maven2/com/facebook/...
  • Вопрос задан
  • 44 просмотра
Пригласить эксперта
Ответы на вопрос 1
@davidnum95
Вообще в таких ситуациях лучшим решением будет создать новый проект с нужной версией рн и туда перетащить весь код
Ответ написан
Комментировать
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы