@impetuous_person

Как решить проблему с OpenServer?

Не удалось запустить MySQL-8.0

За все это не шарю, совсем новичок в этом. Активно погуглил, но вопрос остался не решённым.

Пару дней назад начал писать на PHP. Смотреть что это такое и так далее. Дошел на работы с Базами Данных. Использовал OpenServer для создания локального сервера. Смотрел информацию сразу их нескольких источников чтобы сверяться - все было идентично и все делал так, как было сказано.

Так вот, чтобы работать с БД (PhpMyAdmin) нужно в настройках указать MySQL-8.0 (по умолчанию "не использовать"):

60d2235051332168649718.jpeg

После этого все сохраняется, но в логах к OpenServer можно увидеть следующие интересные записи:

60d223c4b28fb245682096.jpeg

Как с этим быть? После этого даже OpenServer не запустить - при клике на "Запустить" флаг отображается жёлтым и потом снова красным.

Как я уже сказал - я в этом не шарю, но прежде чем сюда писать я проверил форум OpenServer, нашел обсуждения на других форумах. Видел там подобного рода вопросы, но на них либо не отвечали, либо если и отвечали - то данные способы не помогли.
  • Вопрос задан
  • 106 просмотров
Пригласить эксперта
Ответы на вопрос 1
Anonymous24
@Anonymous24
Понедельник, это как вторник, но только вчера.
Как вариант: в настройках (HTTP, PHP), везде поставить PHP8.
Или: заходим в Панель управления/Региональный стандарты > на вкладке дополнительно убираем галочку с `Бета-версия: Использовать Юникод`

https://ospanel.io/forum/viewtopic.php?f=3&t=431
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы