@IVBAN

Есть ли функция в excel нахождения подстроки в строке?

Есть два столбца, нужно как то выделить строку если в ячейки из одного столбца содержится подстрока из ячейки другого столбца в рамках одной строки. если можно обойтись без vba
  • Вопрос задан
  • 36 просмотров
Решения вопроса 1
@anoriyuriy
Желательно приложить минимально воспроизводимый пример.
То есть: Как сейчас - Как надо

По описанию, проблема решается просто. И формулой и условным форматированием, если действительно нужно именно выделить.

Решение формулой

Если в столбце A строка, в столбце B подстрока, то в C можно применить эту формулу:
=ЕСЛИ(ЕЧИСЛО(ПОИСК(B2;A2));"содержится";"не содержится")

60c112a72505c908594466.png

Данная формула не содержит контроля пустой ячейки в столбце B. Его можно добавить, чтобы исключить ложные срабатывания:
=ЕСЛИ(B2<>"";ЕСЛИ(ЕЧИСЛО(ПОИСК(B2;A2));"содержится";"не содержится");"цвет не указан!")

60c1138f21a88953767032.png

Решение условным форматированием

Выбираете "Условное форматирование" - "Создать правило" - "Использовать формулу для определения форматируемых ячеек" . Ввести такую формулу:
=ЕСЛИ(ЕЧИСЛО(ПОИСК($B2;$A2));ИСТИНА;ЛОЖЬ)
В "Применяется к" указать нужный диапазон: =$A$2:$A$5
Результат будет выглядеть так:
60c117bf20a72392353201.png
Ответ написан
Пригласить эксперта
Ответы на вопрос 1
@ClearAirTurbulence
FIND \ ПОИСК
The Excel FIND function returns the position (as a number) of one text string inside another. When the text is not found, FIND returns a #VALUE error.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы